97 venture secondary clutch settings - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-08-2019, 04:13 AM Thread Starter
Registered User
 
Join Date: Oct 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
97 venture secondary clutch settings

Good day everyone,

I’m new to the forum but not new to sleds. I acquired a 97 venture 600 two up a few years ago and when I got it everything ran great and I had no issues. I let it sit for the summer and went to fire it up and it’s running great but won’t go above 40km with anyone on it. If I prop the back end up and hit the throttle it hits 90 to 100km no problem.

I’m thinking that when I pulled the clutch apart I didn’t set the secondary back to the right setting. I’m wondering if there is anyone that can let me know what the proper oem settings are for the secondary clutch are as the primary I pulled apart but didn’t change anything.

If there is anyone that can help me it would be appropriated as I had to watch everyone ride last year and I had to sit out because I could not get it sorted out last season and I don’t want a repeat of that.

Thank you
Darklcd807 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-08-2019, 07:02 AM
Registered User
 
Join Date: Sep 2018
Posts: 1,087
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
What did you do different?
I would also advise you clean your carbs every preseason
KCCats2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome