Snowmobile Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
I have a 600 triple and for some reason oil is leaking out of the clutch side injector. It slowly accumulates in the case especially when I store it over the summer. I've taken apart the pump and inspected it and don't see anything suspicious. Anybody have an idea why this is happening?
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
Yep. 5 checkvalves. The three to the cylinders are good. The other two are suspect. I replaced one and the other is backordered. Not sure how these two checkvalves affect oil flow but I figure I better replace them. It is very difficult to find info on how these oil pump works. Internals etc. Dealer isn't much help.

Thanks for the response.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
YEEEE HAAAA!!! Got it runnin! Felt good to grab a handful and stand it up on some hardpack. I reek of sled exhaust and liking it.
I took the kids for a ride around the field near my sub. Fun fun.

I replaced the two check valves and put the motor back in. I left the injection lines disconnected from the cylinders and mixed the fuel. I then started it up and let it idle. After pulling on the pump arm, oil slowly pumped from the lines. I'm not sure if the injector is still leaking but I know for sure my oil pump works. I connected the lines back up and dilluted the mix in the tank with about 5 gallons of fuel. A little extra oil won't hurt since my motor is fresh with new pistons and rings.
 
1 - 4 of 4 Posts
Top