Snowmobile Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Somethings wrong with my 97 ZR 580 EFI. I was running it on the trail (prolly around 45) when it just died on me. I tried to start it up but it was tight when I tried to pull so I figured the engine was seized up. I then tried moving the drive pulley...it seemed rather tight but it did finaly turn over. (maybe when engine died it was stuck at top dead center?)I then tried starting it again since it wasn't tight when I pulled back a little on the starter rope. It would start after a few pulls but it idled like crap(also was real quiet couldnt hear any noise from exhaust and I have a can) and would die.


I have no idea what is wrong. Hoping it isnt the bottum end. Any help would be appreciated.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Pretty sure my other thread is dead besides one guy looking at it so I started another, besides the other thread had nothing to do with my sled f'in up.


Plugs actualy look pretty good? If the bottum end was bad I wouldn't be able to cycled the drive clutch manualy would I?I dont know much with small engines, prolly going to have to just drop it off and get an estimate.
 

·
Premium Member
Joined
·
34,103 Posts
You could and it can still be AFU.
Better that you open it up yourself and post pics, we can help you diagnose and fix it a lot cheaper than a dealer will.
 

·
Registered
Joined
·
18 Posts
Well i am only guessing a hard one. But my sled did the same exact thing. I tried to pull it and it was stiff like your explaining. Try getting the track in the air and then starting it. the clutch may be stuck in an engaged position. if you get it started with it in the air rev it hard and see if it disengages. Thats all i can think cause it sounds like what happend to me.
 

·
Registered
Joined
·
165 Posts
Ya the same thing happened to me on my 97 580 i went to pull it and it was hard as hell the clutch was engaged , i ended up having to get it rebuilt.............maybe thats what you need to do not sure.........
Have you looked at your clutch? Does anything looked kicked outta place
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Just got done talking to a guy that looked at it for me. He said the pistion skirt went out and ended up getting into the bottom end...said there is chunks all over. Would require a total dismantle and cleaning.

What do you guys suggest it do? Sounds like finding a new motor or parting out is my only options really....
 

·
Registered
Joined
·
184 Posts
There is some specialty tools required to do it yourself, puller for magneto, clutch puller, a torque wrench and a manual would be required, It may be in your best intrest to get it fixed at a shop if you dont want to spend the money on the tooling. The job itself isn't all that hard, just time and a bit of mechanical knowlage. Parts are a not near as spendy if you do it by your self.Having a dealer install them would be a great deal more.
Good luck
 

·
Registered
Joined
·
184 Posts
My rule of thumb is, You get what you pay for. The add doesnt have very much info. What is the compression Etc.. 700.00$ is not all that bad if it is in great shape. It would be nice to know more details on the motor. how many owners. what kind of problems did it have in the past etc.. Why is the motor for sale any ways. These kinds of things I would find out before making a desision (If I were to dish out any money)
As for it fitting I am not sure.
 
1 - 11 of 11 Posts
Top