Snowmobile Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys new to here and yamaha sled world. I was hoping i could get some advise on a issue im having with my 85 ss440. It will start up and run like hell then when you hit around 35-40 it falls on its face. Im thinking its eother a float adjustment or a fuel pump issue cuz if you give it a little time at light throttle it will take off. Also the keihin carb has a mixture screw on top that doesnt change anything at all when i move it, any ideas what could cause that. I love this sled but i hate that carb is there a good swap for them? maybe dual carb. Thanks in advance everyone.
 

·
Registered
Joined
·
75 Posts
have you given the carb a good thourough cleaning if not i would definately start there if you already have then it sounds like you are on track thinking possibly fuel pump is fuel fresh or old fuel now only seems to last a couple of months at best
 

·
Premium Member
Joined
·
5,737 Posts
also look at the fuel filter in the tank and the hose attached to it as well as verifying the tank breather hose is free from kinks or obstruction. you would be surprised at the spiders that make there way into that vent line.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
new fuel that was my first step lines are new and so is filter. that carb was rebuilt by the guy i bought it off of. I bought it off a family member and it has been totaly gone thru. Its in real nice shape besides this problem. Just need to find a original ss hood and figure out this issue, ill check the vent line it sat out all summer so ya never know.
 
1 - 4 of 4 Posts
Top