Snowmobile Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi guys

Having some idling issues with my 2005 Yamaha Rage RS90.

When I start up from cold with full choke will start fine, once warm and choke is off will idle around 1000rpm but if I slightly touch the throttle rpm’s jump up to 3000 rpm and stay there unless I pull the choke and push back in then the rpm’s go back to 1000 until I hit the throttle again and will do the same thing.
I have checked the throttle cable and it seems fine and have ran some sea foam thru with no difference. I would add a video if I knew how! Lol

Thanks in advance for any suggestions you may have.
Thanks
 

·
Registered
Joined
·
1,329 Posts
Clean the carbs...

That is the first symptom on my RX that it wants its carbed cleaned. (called hanging idle) One of your idle jets is most likely plugged. Running seafoam (or any chemical) doesn't do much of anything, you have to pull the carbs and mechanically clean the jets individually (fishing line if possible, blast with carb cleaner tight against it and finally a shot of compressed air)

Compared to a 2 stroke, the idle jets on the yamaha's are incredibly tiny! They don't take much to plug up. If you haven't had the carbs apart for a couple years, also going to want a set of o-rings for the jet and the float bowl. Those sometimes stick &/or are damaged when you remove them. (21 & 29 on the diagram) You might be fine without, or you might rip them and have to wait to get a replacement in stock.


Also you want your warm idle to be up around 1400 rpm or so. It is happier, and the clutch doesn't clank around (as much) if you are near the top.
 
1 - 4 of 4 Posts
Top