Snowmobile Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Noticed a clanging sound coming from the motor. Removed flywheel cover (partially)
Tape measure Tool Font Rectangle Measuring instrument
Motor vehicle Automotive tire Bumper Tread Tire
Automotive tire Motor vehicle Hood Automotive lighting Vehicle
Tire Wheel Automotive tire Fuel tank Vehicle
and found this (see images). Not sure if this is part of the motor or someone's left over Allen key?
Thoughts?
Thank you for any assistance.
 

· Registered
Joined
·
495 Posts
That looks like an allen wrench that may have fallen into the motor when someone was doing some work. It finally found it's way to the magnet. Did you find any other pieces in there? I would pull the cover completely off and make sure everything looks intact. If there is nothing missing/damaged/extra, put the cover back on and fire it up.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
That seems the general consensus. The dealership had done some work on this snowmobile just after it was purchased. I would need to take out the motor to fully remove the flywheel cover. I may need to anyways to put the cover back on again..... Some of those bolts were very difficult to access ....
 

· Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
The clanging sounds only started after I had the sled on its side to inspect the track - this must have dislodged the pesky Alen wrench from wherever it was stuck and dumped it in the flywheel cowling.... At least that's my leading theory. I just glad I didn't have to pull the motor :p
 
1 - 10 of 10 Posts
Top