Snowmobile Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys, I've got an 87 saffari 377 that runs really strong. (no problems top end) The problem I;m having is it won't Idle and if I hit the gas it bogs out then takes off. I've clean the carb, changed the plugs. andput good fuel. Any Ideas would be helpful. Thanks:confused:
 

·
Registered
Joined
·
31 Posts
Sounds like you may have a clogged jet. Did you take the carb off and strip it to clean? I had to do this on my sled (see sig) then it ran like a top. Your carb floats may need adjusting. If you cant get it to idle, but it takes off after giving it the juice, your float level might need to be adjusted. Have you played with the idle adj screw?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
I disasembled the carb. 100% everything is clean. If I try to adjust the ilde nothing happens. It doesn't go up or down. Compression is 125 both cylinders no airleaks or fuel leaks.
I'm going to take it apart again to day to double check everything.
Just to refesh: the air adjust screw should be adjusted one and ahalf turns (mikuni} .To adjust the floats I just bend the float level??? I got it set level right now???
Thanks
Dave
 

·
Registered
Joined
·
31 Posts
Scoty,

I don't know if your sled has a fuel filter, if it does change it. My 83 does not have a fuel filter? If it does I can't find it! Your idle screw should change the RPM's! If it is not doing something when you turn it (while running) something is wrong. Your correct on the float adjustment. You'll want to adjust it so that more fuel stays in the carb.

The air adjust: Now I am no great mechanic, but I adjust mine in 1/4 turns.
Don't forget more air=less fuel (elevation) less air=more fuel.

I hope this helps. I sure don't want to tell you something wrong that adds to your problems!
 
1 - 6 of 6 Posts
Top