Snowmobile Forum banner
1 - 7 of 7 Posts

·
Team Arctic
Joined
·
746 Posts
Discussion Starter · #1 ·
today i was riding home from a friends place and right out of no where i hear this big clunk. so i start slowing down and i could see the secondary moving back and forth on the jackshaft. So as i got stopped i shut it off and opened it up. Sure enought i fing that the bolt has come out of the shaft. so i grab it and as i was reaching for it i found another nice little present, one of the arms on the spider was laying beside the bolt, and a wieght. The spider must have been cracked because it broke pretty clean off and when it broke the wieght must have snapped to. :( So now i'm to the stage off what to do with it. i've only had this sled a weekk and already so much has went wrong... i hope this is the last fix i have to make. When you are putting on one weight you shoudl probly change all three right? and the spring while you in there anyways... Well i guess i just had two little questions sorry to bore you. Answers welcome.
 

·
I am Spartacus
Joined
·
23,863 Posts
Yes, replace all 3, as well as the spring and the bushing that the one side of the secondary rides on. A lot of times this causes the problem by making the sheave open crookedly. It's pretty easy to replace all these parts.
 

·
Team Arctic
Joined
·
746 Posts
Discussion Starter · #3 ·
thanks, i think i will just be replacing the whole primary clutch. If i can find one - backordered till march 15. I think i'll take your advice and buy the bushing too. is it like a long cylinder?
 

·
Team Arctic
Joined
·
746 Posts
Discussion Starter · #5 ·
thanks for the advice, i found a clutch today too so i should be on my way in couple of days anyways, depending on when it gets here.
 

·
Runnin Against The Wind!
Joined
·
8,036 Posts
I don't mean to be negative, but a friend of mine who had an Artic cat had constant clutch problems over and over and over, not to speak of the other problems. He finally purchased a Yamaha and has been happy ever since.
 

·
Team Arctic
Joined
·
746 Posts
Discussion Starter · #7 ·
i know, every brand has their lemons though. We've been runnin cats for about 7 years and this is one of two problems we've had, on one of our old 95 pumas we broke a crank and now this clutch. I got the new one this morning, also found out that someone had chaneged the wieghts from stock. i might buy a clutch kit for it, not sure yet, this clutch was enuf money already.
 
1 - 7 of 7 Posts
Top