Snowmobile Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
A friend of mine has a 00 ZRT 600. When he bought it, the key worked fine, but after a few riding weekends, he could not shut it off. He replaced the CDI box and this fixed the problem for about a month, but then when we rolled up to a gas station he couldnt turn it off. I read that the 96 style had an issue not shutting off as well, but I was wondering if the 00 is any different. I checked the connections in the velcro and they were clean so I am not sure what else to try (the proposed fix for the older chassis). I find it hard to believe that the machine is frying CDI's. TIA for any input!

Rich
 

·
Registered User
Joined
·
710 Posts
Does the kill switch work? Does it have a teather cord? Check all of the plugs for connections and make sure there is no broken or worn through wires. Sounds very simple whatever it is. I had a simailr problem with my sled. If it has a teather cord then sombody might have altered the routes of shutting the sled down meaning bypassed on piece or another.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
Kill switch does not work and sled does not have a teather. Only way to shut it down is choking it. We will have to check the wiring this year. He thinks that it is frying CDI boxes, but I don't think that is the case. Thanks for the reply!!!!
 

·
Registered
Joined
·
155 Posts
It sounds like a ground issue. Check the ground wire that uses the muffler mounting screw. It may have some corrosion in the wire or terminal. Make sure the star washer is making good contact with the chassis.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
Frosty,I will check that out. The sled has a can on it so seeing down there shouldnt be a problem.

smallengine, I almost yelled at him when he said his sled fried another CDI unit. There is no way the sled would burn them up ans still run like it does.

Thanks for the tips guys, I cant wait to bring my sled home and get it ready for winter!!!!!!
 

·
Registered
Joined
·
68 Posts
Yeah, when CDI's go, doesn't the machine stop? They're solid state so once they go, they're toast.....you shouldn't have any spark if your CDI is shot.....
 

·
Registered
Joined
·
128 Posts
my shop manual from arctic cat says if your engine does not shut off and all your switches are working properly it IS the CDI
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #9 ·
Hmmm this poses a flaw in my plan. Does your manual have any possible causes for CDI failures??? Thanks for checking the book for me!!!!!!
 

·
Registered
Joined
·
128 Posts
the manual says...

"Problem: Engine fails to stop (continues to run, even with all switches off)

Condition: CDI unit shorted to ground

Remedy: Replace CDI unit
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #12 ·
gEXTspecial, Thanks for all the info. It is appreciated!!!!!!!!
 
1 - 12 of 12 Posts
Top