Snowmobile Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 94 XLT, and i put and 96 Xlt motor in the sled, along with the carbs and everything. But noticed the the cable coming to the throttle was a little short when turning and was pulling on the carbs and wouldnt start vary good.(flooding) i think.

but when i took the cable out of the throttle and left it sitting there with no tension, sled would fire on first pull. i tried getting longer cable (97) and was too long and wouldnt start at all just flooding it. got a (96) cable and was still little short. I even moved my throttle up the bars a bit.

Not sure if im installing it wrong? seems the cable coming from the carbs are tight and not sitting freeley? Not sure what to do?

sorry for the long read.
 

·
Registered
Joined
·
17 Posts
I just ran into this myself. I was switching carbs from one XLT to another. 1 sled had the 38mm carbs... the other had the smaller 34mm( I think)
I switched the carbs... but the cables were to long on one sled.,.. to short on the other.. so I had to switch the cables too.
My guess is the 96 motor has different size carbs then the 94 engine.

The XLT SP... has 38mm carb.. the XLT Touring, or limitied have the Smaller carbs.
Hope this helps.
Reaney in NH
 

·
Registered
Joined
·
17 Posts
You can take up alot of slack on the longer cable with adjusting the screws on top of the carb... Screwing them out will effectively make the cable shorter.

My guess is your old engine had the 38mm carbs,,,Your new one has the 34mm...
 
1 - 4 of 4 Posts
Top