Snowmobile Forum banner

1 - 5 of 5 Posts

·
supa-rider
Joined
·
51 Posts
Discussion Starter #1
so today my friend asked me to get his sled out of the shed for him... to make a long story short the do not understand how to store a sled right.... but last year it was doing the same thing.. its a 2003(i think) ski-doo grand touring 600 carbed.. it will go but not over like 20/30 mph it just cuts out like the computer is telling it too... what could this be?? please someone help.. or should i tell them to bring it to a dealer and put it on the computer..

P.S. the speedometer also dose not work if that helps
 

·
twins rule!
Joined
·
370 Posts
I would start by draining out the old gas+instaling new plugs+pulling off the fuel bowls on the carbs to see what they look like.
 

·
twins rule!
Joined
·
370 Posts
also pull off the spedo cable+drive cover+check the bearing under it rof play or damage although this has nothing to do with the way the engine runs.
 

·
Registered
Joined
·
794 Posts
I would start with getting rid of the old gas and cleaning the carbs also take a look at the carb boots as they are well known for cracking in those years. as for the speedo I beleive it has an electronic pickup and not a cable. Up under the dash you should see a couple little black ice cube type relays should be two if it has electric start. I would try swapping their locations and see if your problems change. if you take one of these relays to your local napa store they can match them up at a much better price then from the dealer.

I would start with these things and see what happens.
 

·
supa-rider
Joined
·
51 Posts
Discussion Starter #5
ya carbs is possible i can give that a shot
 
1 - 5 of 5 Posts
Top