Snowmobile Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
i got a 1993 ski doo mxz 583....it has the rotex motor and got some engine work done to it.
it starts and itll run for a couple seconds but then it will die and bog down.
cant find out the problem with it. the carbs are clean and everything. i was wondering if you had to run sertain plugs? i got ngks in them and i heard before that rotex engines might need champions? give me some help guys
 

·
Yukon Powder hounds!
Joined
·
20 Posts
Try checking the fuel lines under your carbs to see if they are restricting fuel flow. Also stay away from champion plugs they are the worst throw them things as far as you can stick with nkgs. check the owners manual to see how hot the plug should be (the number on the plug) If the plug isnt hot enough you will keep fouling
 

·
Registered
Joined
·
61 Posts
i got a 1993 ski doo mxz 583....it has the rotex motor and got some engine work done to it.
it starts and itll run for a couple seconds but then it will die and bog down.
cant find out the problem with it. the carbs are clean and everything. i was wondering if you had to run sertain plugs? i got ngks in them and i heard before that rotex engines might need champions? give me some help guys
No I was runnig NGKs in my old 583 ad 700, the same thing was happening to me , all i did was replaced the seal between where the pipes leave the motor, there was air getting in to engine
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
okay ill see if there is any kinks in the line or anything like that.
the seals on the exhaust are fine. but ill check again it ran a couple days ago fine. didnt have anything funny going on till this started to happen.
thanks for the edvise. if you guys got anything else let me know
 

·
Registered
Joined
·
61 Posts
You could also have q problem with your spark plug caps, my 583 used to rattle the cabels loose and shut off, and it also could be that when I had the primer on her the valve got stuck and she would keep feeding fuel and bogging down
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
You could also have q problem with your spark plug caps, my 583 used to rattle the cabels loose and shut off, and it also could be that when I had the primer on her the valve got stuck and she would keep feeding fuel and bogging down
okay thanks....ill see if thats might help.
 
1 - 6 of 6 Posts
Top