Snowmobile Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Got a big problem. Started my sled and ran it for about 3 min, loaded onto trailer then headed for the lake. Went to start it without priming and didnt fire up. primed it 3 times and it didnt fire. Open up the hoodand all hell broke loose! i had gas spitting out of fuel pump and running out of exhaust. Let it set for awhile went back out took out spark plugs and pulled and ALOT of gas came shooting up out of cylinders. Why would i have so much gas flowing when there shouldnt be?
 

·
Sled Of The Month Judge
Joined
·
2,841 Posts
stuck open needle valves would cause this.

screw in the adjusting screws until lightly seated, counting the number of turns. don't over tighten. Then take off the float bowl and take out the jets. Stick a wire through each jet,to remove varnish. Take the float out, and the needle, and inspect the seat. Clean all of the passage ways in the carb with compressed air. If the needle continues to leak, get a rubber tipped one.
 

·
Mountain Man
Joined
·
423 Posts
Fuel pump took a dump and you are putting gas thru impulse line. A sticky float/needle shouldn't have a effect on fuel pump. it being upstream from pump.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Ok i cleaned out my carb and got a new fuel pump diaphram. I have pulled it ALOT without the spark plugs in it. I still have a little gas spraying out of cylinders and sum gas running out of impulse line. Wondering what my next step should be.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 ·
Got snowmobile going. Ran like it was only running on one cylinder though. Next day went to start sled and acted like it was seized up. Finally got it to roll over and it started the fuel leakage again. Do i have a big problem?
 
1 - 7 of 7 Posts
Top