Snowmobile Forum banner

1 - 5 of 5 Posts

·
jcurrieta
Joined
·
197 Posts
Discussion Starter · #1 ·
So I bought my 03 RX1 sled and it has K&N filters on it and jetted,,,, but i find im going thru alot of oil,,, only place i can see it wet is around the small vent filter,, its saturated and getting all over the place?? whats up?? Is this normal?
 

·
Premium Member
Joined
·
5,737 Posts
i read a tech bulletin on that issue not long ago. i tend to not absorb the 4 stroke info much because i rarely have the chance to mess with them.

your issue is not normal and should be looked into. i think it had to do with a breather hose freezing from using the sled in extreme cold temps. your dealer should be up on the issue, or at least be aware of the bulletin. it wasnt a warranty item, just a "heads up" as gasket failures could result from the pressure buildup.
 

·
jcurrieta
Joined
·
197 Posts
Discussion Starter · #3 ·
im not sure how much info a dealer would have,,,,, u do understand its saturating the little K&N "Vent" filter,,, not the stock air filter. Do you know where you read the info?
 

·
ride till your broke
Joined
·
2,560 Posts
i remember in snowgoer mag that they had
an upgraded breather for extreme cold use.
guess stock one freezes,pressure builds up,
then it thaws and oil goes everywhere.

from what i remember? been awhile ago.
 

·
Premium Member
Joined
·
5,737 Posts
read the info in the 2005 yamaha technical update bulletin.

rememdy is to cut a 3/4" slit lengthwise in the breather hose inside the airbox.

also an interesting article about a "ring free" product. i think i am going to try some.
 
1 - 5 of 5 Posts
Top