Snowmobile Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi everyone. Wife's 340 has allot of play in the skis, allot. Must be a simple fix but I really am far from experienced with working on snow machines. Can someone point me to a repair manual? Thanks in advance.
 

·
Super Moderator
Joined
·
18,335 Posts
There are some links to manuals online in the engine/driveline portion of the forum, but won't be specific to the Indy 340.

I would check the nut that is attaching the steering linkage to the steering column, it often comes loose on Polaris sleds. I have had 3 Edge models and they were all loose, resulting in loose steering. It's a bugger to get to, you may have to remove the motor mount bolts and move the engine out of the way to get to them.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Thanks Dan. I just went to check and it sure seems that the motor needs to move out of the way to have a clear view. A little above my skill level to take the motor out. Thanks again.
 

·
Super Moderator
Joined
·
18,335 Posts
Edge motors are pretty easy, especially the fans. Remove the pipe/can, remove the two front nuts, remove the back nuts (2, maybe 3). Lift the engine without disconnecting the throttle cable or oil/fuel lines, it should give you enough access to tighten the nut on the bottom of the steering column. You shouldn't have to remove it completely, just move it enough to get a wrench on the bottom nut.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
Checked everything today and looks like just the tie rod ends are shot, all 4. Any info on a good online supplier? Local Polaris shop want $280plus for 4 ends and 2 rods and they don't have anything in stock. Figured I may as well price hunt if I have to wait on parts anyway.
 
1 - 5 of 5 Posts
Top