Snowmobile Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,057 Posts
Discussion Starter · #1 ·
just got kid this sled has 521 in it runs good but not to familiar on this suspention when i lift back about a foot or betterof ground the front track is still on ground is something broken or this is the way they are it dose lean to the left when sled is on ground like somethings broken thanks:dunno:
 

·
Registered
Joined
·
5 Posts
if it the front shocks they are not that hard to change- i also havea pair i just took off my sled when i replaced w/fox shox-they are still good if you need a pair? if it the front shock of the rear skid they are a lil trickier but not to bad but there is only 1 shock in the front of the rear skid. i would check where the skid bolta into the tunnel and make sure all is good there... does the track stay tight or keep losining up? be sure to grease the zert for the drive shaft that turns the track-i have seen a lot of sleds that did not get greased and that bearing get so hot that it melts the side of tunnel-you may already know this but thought i would throw it out there...
 

·
Registered
Joined
·
100 Posts
PRS had a front limiter bolt. The bolt goes from the front trailng arm, down and back to the front of the skid.

It has a 17mm nut on the bottom, you should see 3/4-1" of thread below the nut.

People use to back them off to do wheelies.
 

·
Registered
Joined
·
1,057 Posts
Discussion Starter · #8 ·
prs on formula plus

ya thats where most of problem seems to look funny it rides good but as if front of skid just floats i see shock up there running length wise and a h frame that pivots but something dont seem right i will check on that bolt thanks plus still have no lights hope it is voltage reg and not in stator.:confused:
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top