Snowmobile Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 94 zr 580,anything before 5,000 rpms she just boggs down once it hits 5000 rpm it takes right off full power,Now ive rebuilt the engine 2 times,had the carbs tuned,then tried a different set,still didnt work tried 2 CDI's,coils,2 different primary,secondary clutches,Belt is good on it. Carb saftey switches are disconnected because the sled wouldnt run with them plugged in.Fuel system is fine,good compression,excellent base pressure,I cant figure out whats wrong with this sled if anyone has any ideas please let me know.I ran 1 finale test and when i had the crankcase out i fill it with liquid on one side. i dont know if it is suppossed to leak from one side to the other and if it is how fast,The only thing i can think it might be is the crank center seal.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
the air screw is turned out 1 1/2 turn thats the specs from the book and ive tried just 1 turn out no difference.
 

·
Super Moderator
Joined
·
17,191 Posts
Like RJ said. On my old 94 ZR carb, I had to set it at 1/2 turn out to get rid of the bog. In is more fuel, those 40mm carbs are gas hogs! If you keep turning in the screw and there is no improvement, go one size larger on the pilot jet and try it again from the initial setting.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
i got rid of those 40 mm carbs they were nothing but problems,they were designed to big for the 580 so i was told to put 38mm on from quite a few people it got better but that low range bogg is still there but as soon as i hit 5000 takes right off and runs fine.Ill give that a try.thanks
 
1 - 6 of 6 Posts
Top