Snowmobile Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
ive seen on a couple sites so far polaris released it today( no pics yet) i guess the dealers had a conference call today about it. All black, fusion front suspension RMK body 144" track. WOO HOOO! cant wait to see pics.
 

·
Registered
Joined
·
711 Posts
what really??? when you get an idea of a website or pics let me know!!!!
 

·
Registered
Joined
·
3,316 Posts
Wow that looks so sick!! Dano you shouldve waited another year!
 

·
Administrator
Joined
·
1,152 Posts
proXpilot said:
here is a small pic.
Wow.... Now I'd be interested in a 144" Polaris if it had that setup.... still have yet to test the 800 Switchback (please snow and freeze at Duluth soon.)

That is a hot looking sled.
 

·
Registered
Joined
·
3,316 Posts
Yeah, my dads friend just bought the fusion and it cost him 10000 so i would imaginf that sled would cost that much too. I wish i had that kind of money lol!
 

·
Mountain M0DERAT0R
Joined
·
7,469 Posts
holy heII that sled is awesome looking:eek:

*dano/cobra if your looking for info for an update for the home page... find somethin on that:D
 

·
Registered
Joined
·
711 Posts
hmmmm, i think i will stick with the 2004 for now. after today it now has 2 miles on it !!! tonight it will have closer to ten after i get out of work.
 

·
Registered
Joined
·
3,316 Posts
Dano how do you like the new sled so far?
 

·
Registered
Joined
·
711 Posts
hey Snow Freak,

so far so good. since it is new and has been sitting, the throttle stuck on me in the middle of the road. only about 5000 rpms though. so i hit the switch and got stuck in the road with traffic coming. i guess i can lift 500 lbs off the road in an emergency :) then the cable came off the plastic throttle itself. grrrr, got that back on and now we're good. so far i like it but as with new polaris engines, it kinda over revs. sounds like there is no belt. but my cuz 02 600 does this as well. i have to give it half choke to idle it down. i dont think this is actually a problem. it is a big engine. I am used to a 700 with different carbs and not the VES. over all i think it is a great sled thus far. rides nice, plenty of power.

:)
 

·
Registered
Joined
·
3,316 Posts
Dano,

Thats weird that the throttle stuck on you, especially in the middle of the road!! But maybe you need to break that baby in! :D
 

·
Registered
Joined
·
711 Posts
well thats just it, there has been heavy mosture in the air, enough to get into a line and freeze, and the throttle also never been used period. plus it has been sitting in a box for a year. i am not to worried. just got to run some lube through it.

now i got all the red parts switched over to yellow with a yellow skid plat. slmost done. got to chage the handle bar hooks to yellow and the mountain bar to yellow. By the time i ride in Michgan over new years i should be all decked out.
 

·
Registered
Joined
·
3,316 Posts
Post some pics!!:D
 

·
Registered
Joined
·
711 Posts
working on it, i have an awesome pic of the two sleds but the pic was too big and i couldnt post it. i even took it small so i could. o well. it emails weel but i will have to retake it or have someone resize it for me. i know not how :)
 

·
Registered
Joined
·
3,316 Posts
Send the pic to my email [email protected] and i will resize and post it for you when i get home from school.(im at school now and i cant get on my email here)
 
1 - 20 of 23 Posts
Top