Snowmobile Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
500 Posts
Discussion Starter #1
Well, finally got around to mess with this a bit. Decided to go ahead and do some cleaning. One thing I have a problem with is that it doesn't seem to have much power and doesn't want to idle at all. I guess I will have to get a carb kit and clean it out. Seems to run fine once the RPMs get up there a bit but it shure doesn't like taking off. Any ideas what I should do with the idle issue let me know. Messing with the idle and mixture screws didn't help anything. It also smokes like a cheap cigar. I know the previous owner did dump the old gas and put fresh in but I don't know what mixture he set it at (and should be be what 40 to 1?) or what sort of 2 cycle oil was used.

before pics




After I cleaned it up and re-striped it and installed a new windshield.

 

·
Registered
Joined
·
470 Posts
Carb probably just needs to be taken apart and cleaned well. The idle problem is probably just a plugged pilot jet. The sled looks in great shape. I would check the cranks seals as well with it being as old as it is.
 

·
Vintage Sled Pilot
Joined
·
533 Posts
Nice piece of old iron!!! Glad to see another sled resurrected and another vintage fan! Is it going to be a rider?
 

·
Registered
Joined
·
500 Posts
Discussion Starter #4
Yep, just something for my boys to jump on if we ever get enough snow. If I can get it to idle right then I can check to see if I have a seal leaking.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #7
OK thanks. If we get some snow this weekend I will try to snap some pictures from my camera. These above were from my phone and they dont look too good.

Have another question. The guy I bought it from said it ran fine but the track would slip in heavy snow. I looked at it pretty good when I was cleaning it up but the track looks great. I took the chain case off and it too looks fine. Could it be that the track is stretched and may need to be tightend up or something? When I ran it a little yesterday it didn't seem to have a problem. But, when I bought it and was loading it on the trailer I thought I felt it slip.
 

·
Break out the duct tape..
Joined
·
576 Posts
Sled looks great!:thumbsup:
 
1 - 13 of 13 Posts
Top