Snowmobile Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
Just picked up a 2003 Polaris with perc. Cant figure out the reverse. Says to push in yellow button then light blinks. Well i do this and sled dies and have to restart it Got it to work once but dont know what i did.
Thanks
 

·
simy03
Joined
·
74 Posts
Same with mine, warm it up good before you try it.
 

·
ride till your broke
Joined
·
2,560 Posts
even on my rev i cant start it then use reverse till it
runs for at least 10-15 seconds.
 

·
Registered
Joined
·
181 Posts
i have a couple of sleds with perc and it works hot or cold. that being said i have helped a couple of buddys get there perc's to work. idle speed needs to be right on one we had to readjust the tps. and one guy had his belt deflection to tight and it would make it stall! i have also heard of the switch getting corrosion on the conection causing a stalling problem. could be a few things you will need to eliminate the obvious first, like the idle speed. good luck
 

·
Registered
Joined
·
234 Posts
Ride the sled around for a while to get it warmed up. Let go of the throttle and hit the PERC button. The engine should idle down to a point where it almost sounds like it's shutting down, then it should come back up with PERC engaged. Do not throttle hard at this point; feather the throttle until you feel it engage (sounds like a clunk). Now you're ready to go backwards. Same process getting the sled in forward.

If it continues to stall out when warmed up, you may need to adjust the idle. The sled when warmed up should idle around 1400 to 1600 RPM.
 

·
Super Moderator
Joined
·
18,335 Posts
Along with the things whiteghost has suggested, the PERC system has two settings. One is for low altitutde, one is for high altitude. You can tell which mode your sled is in by the speed that the light blinks (fast or slow.) To change from one mode to the other, hold the PERC button in and the reverse light will change how it blinks. Sometimes going to the opposite mode will allow the reverse feature to work better.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #8 ·
Well have to try it out more. It usually is when its not fully warmed up it dies. I did hold the perc button in and did notice it flashed faster like said. I think thats when it worked the one time but it was probably warmed up some too. Well have to take it out this weekend and see how it works. It only had 90 miles put on from last year to now so maybe soem corrosion to. Thanks for all the ideas.
 

·
Registered
Joined
·
24 Posts
Hey guys,
I have 2-2002 RMK 800's and I am looking to put PERC Reverse in them. I can get 2 kits for a 2003 700, is there any way this kit will work on my 02 800? I know I need to get a 03 oil pump, but is there anything esle? Will the CDI box be ok? Any help is greatly appreciated! Thanks. Jack
 
1 - 11 of 11 Posts
Top