Snowmobile Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
Hi I have an o1 mxz-x, that I bought this last spring and have not been able to ride yet. It has weiseco pistons and v-force reeds, with an air box mod. I'm wondering how I know if I'm getting the right jetting. I looked at the pistons and the burn doesn't look very good "black" way to rich? The plugs are new so that doesn't help. Are there any guides or tools to help me get this to the proper setting? Sled starts right up, and will hesitate from idle to full throtle, I'm guessing bad, low octane gas, I did ad stabil, and I did fog it in the spring. And please somebody, let me know what the proper operating temp is for this sled. I have koso egt guages, but I'm not sure were to set them at. I'm about to head out on the 16th for my B-day and just want to make sure that I'm Good to Go.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3 (Edited)
So. This seems to be correct from the pics. I was told when I bought the sled the main just was way oversized, but that appears to be the same wash I already had. I thought maybe I'd be looking for more of a ashy crust on the cylinder head with the dark color underneath. How about a jetting chart though. where will I find one?
 

·
I am Spartacus
Joined
·
23,863 Posts
You need to get it out in a field, etc so you can give it a chance to get some color to the plugs, etc on a wide open run. Then go from there.
 
1 - 4 of 4 Posts
Top