Snowmobile Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3,519 Posts
I know the TPS should be set at 4.0 with the throttle wide open. I set mine using a tool like the one below that I built and it worked perfectly. Just a FYI as those are known to go out of adjustment easily.


Check the service manual in the link below. Click 1985-1995 it should be there or the 1996-1998 should work as well.
 

·
Registered
Joined
·
3,519 Posts
We did with the volt meter and its 4.0 wide open throttle. I never trusted that software with regards to the TPS. We used to have better luck doing the voltmeter way for some odd reason. I can't recall exactly what the idle mixture we used to set at was. Been too long and I never messed with it on the '92 500 EFI I have that is gonna get parted out as I need the money badly for some auto repairs. I can try to remember to look next time at the parental units house but that won't be till next week most likely.

I swore that the settings were in the service manual for that stuff. Also Big snow is about the last place you can even get that software anymore or how to build stuff for the cables and what not. The TPS tester I built was done from Radioshack parts but you can still get them from eBay and amazon. Takes about 20-30 mins to wire it all up and its dead on accurate. I even thought about making several to sell as they can be decent money makers for what 10 bucks in parts?

Link for some of the service manuals just in case you don't have it. May want to try asking on another snowmobile forum or on the Polaris facebook pages that are out there. IIRC there is a couple RXL pages on there.

 
1 - 3 of 3 Posts
Top