Snowmobile Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1 (Edited)
Heres the deal i have this 96 mxz with a 99 670 ho engine. i got this sled like this at the end of last year and never rode it in the snow... So this year i get it fired up and what not and realize that my 96 formula z 583 is quite a bit faster on top end... on a good night with the right weather i have personally seen 95 mph on the formula z.... the 670 wld only run 70 wide open and then if u kept it pinned for like 45 secs. i seen 80 but it was bouncing between 80 and 100... of course i dont trust the speedo, but just by feel the 583 is way faster.
I have not had time to check this out but i wld like to get some ideas for when i do... idk if its just a worn belt or the clucthes... just looking for ideas at this point. Now the 583 has about 90 studs or so, the 670 has about 150 or more so i dont know if its like more studs tricking me and the track dont spin as much at higher speeds cuz i feel like if the track is spinning it will give a false reading on the speedo or whatever...
I did however do a little research the 96 583 chassis according to a parts catalog has a 25/44 teeth combo on the chaincase sprockets and a 50 degree ramp in the secondary... the 99 670 ho says it had 25/43 (sprockets) and for the ramp it said 47/53 degree. i dont understand what the 47/53 helix means...like maybe there was two options or its spilt some how??? so as far as the take off im impressed the top end is what i am concerned about... so if anybody can throw some ideas out i wld appreciate it i figured this thing wld make my 583 look like a little boys toy but so far not so much.
 

·
Registered
Joined
·
350 Posts
Discussion Starter #3
the sled is a 583 chassis originally i dont think i made that clear... So for starters would the extra tooth on the bottom sprocket make it faster or slower on top end??? Also in the secondary just wondering if anybody knows if it is like a polaris where u can adjust the backshift pressure by tightening the spring??? Because its like it hits top gear to soon or its not even hitting it at all. I didnt have a look at the belt yet but wouldnt a worn belt be killing top end also??? idk but my uncles 97
 

·
Registered
Joined
·
350 Posts
Discussion Starter #4
well im still looking for ideas if anybody can help... I was saying in the last thread my uncles 97 formula z 583 was also spanking this sled on top end luckily he has no studs and cant touch it on take off.
 

·
Registered
Joined
·
315 Posts
a worn belt can cause what you are describing
always replace the belt even if its slightly worn , dont forget it's the link that's
going to get you back home , you may be having a issue with your clutch as well.
i am somewhat certian the numbers on the helix are the degree of pitch at the start of the helix (47)
and the degree progressed to at the end of the helix (53)
 
1 - 5 of 5 Posts
Top