Snowmobile Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Just picked up this near mint 95 Polaris XCR 600 for $500. It does not run, but does if you spray gas in it, so carb clean and fuel pump/filter service should get this running. Obviously garage kept, all of the decals and everything is still on this, and almost spotless under the hood. Compression is 120-125psi on all 3 holes. It has a track extension on it, and 1.5" track.
 

Attachments

·
Registered
Joined
·
50 Posts
Discussion Starter · #8 ·
Cleaned the carbs up the other day, they had a bunch of dirt in them, but other than clogged jets, the carbs were very clean, no discoloration or anything. Sled fired up and idled smoothly, the next morning it fired up first pull with no choke and a short 2ft pull on the recoil. Now I know it runs, I can start getting it ready. So far it needs carb boots, at least 1 is cracked, going to replace all 3. I'll tear the engine down and measure cylinder clearance, replace crank seals, perform oiling mod, and inspect the mag cylinder as it has a lot of scoring looking in the intake port. It also needs new driveshaft seals and bearings as the chain case leaks. I need to make the hood holder cable thing longer, it's too short to the point that the hood falls closed if you bump the sled.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #10 ·
Yeah, it is an experience that gets old and annoying really fast. I forgot to check if the hand and thumb warmers work, which appear original, and to my surprise both hand warmers and even the thumb warmer work.
 
1 - 4 of 4 Posts
Top