Snowmobile Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
my fathers sled (1997 XC 600) is making a loud clicking noise. it sounds like it is coming from the oil pump but we are not certain. however there seems to be no problems with how it runs and it is still using oil. i would also like to know if the pump is rebuildable.
thanks
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #3 ·
all the time i think, i never got to drive it. it does it while idling and im pretty sure while driving to. its loud when its just idling.
 

·
Registered
Joined
·
125 Posts
This may be irrelevent, but my sled started making a strange clicking noise during our trip to canada. I was thinking it was something in the clutch until my buddy pointed out that my stabilizer bar was a little loose. It shakes around a bit in the pockets on the trailing arm. $14 to replace the stabilizer ends. No more clicking. I REALLY sounded like it was coming from the motor or clutch, but evidently the vibration was coming thru the stabilizer mounts on the belly pan. Maybe check that .
 

·
F.K.A. MOUSE72
Joined
·
3,807 Posts
you know come to think about it, my sled makes thst same noise. It was the stabilizer bar. I would check all the bolts and such from the suspension(rear and front) and even inside the motor compartment.Sometime they come loose over time from vibration. Ity might be as simple as tighting a couple of bolts. if you think it's coming from the motor, take a length of garden hose and use it for a stethoscope and put it on different parts of the motor. it work good, but I would see if all your nuts and bolts are tight.Does the noise have kind of a ringing sound, like a bell? i hop this is helpful
 
1 - 5 of 5 Posts
Top