Snowmobile Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Overall my sled runs great but for some reason when I hit the throttle wide open it boggs and restricts the rpm's at 7,000 or so...it almost sounds like there is a governor on engine.

It has smooth acceleration up to 3/4 throttle but once I hit it full it bogs and I have to back off.

If I hit it full throttle off the line it also boggs.

I have cleaned the carbs but don't know what else to do....any suggestions??
 

·
I am Spartacus
Joined
·
23,863 Posts
Might have to move the c-clip on the carb needles down one notch to let more fuel get through under higher RPM's.
 

·
Registered
Joined
·
41 Posts
I used to have a similar problem on my XCR 700, turns out there was a very small piece of silicone in the fuel pump, when I hammered the throttle and it was calling for fuel, the piece would get sucked down into the bottom and restrict the fuel flow.

After that it was fine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
It wouldn't hurt to move the needle down one notch. I'll try that thanks SmallEngineGuy.


Spiderman,
Did you take the fuel pump apart and clean it or did you rebuild it?
 

·
Registered
Joined
·
155 Posts
The needel setting is for 1/4 to 3/4 throttle. You said it's okay in that range. You said the problem is from 3/4 to WOT. That would be a main jet issue. Either it's really gummed up or you have to large mains in it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
I took the whole carb apart and cleaned all the jets real good. I don't know what the mains are...you see this is my first sled...but I'd assume they are factory cause I have not replaced any parts, neither did the ex-owner.

is it possible the ex-owner restricted full throttle some how? He had an 11 yr old son driving the sled and his reason for selling was it was too fast for his son.
 

·
I am Spartacus
Joined
·
23,863 Posts
Frosty said:
The needel setting is for 1/4 to 3/4 throttle. You said it's okay in that range. You said the problem is from 3/4 to WOT. That would be a main jet issue. Either it's really gummed up or you have to large mains in it.
He said it also bogs from a stop going up to full throttle. Do the needle clip thing to see if it gets any better, then go up a size on the main jets if it doesn't.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
It looks like a rat chewed a hole in my air filter...a little needle tweeking, a new air filter and I hope to have full throttle back.

I pushed my way through a big drift the other night and packed the sled in snow...the throttle bog was terrible right after that.
 

·
Registered
Joined
·
155 Posts
If you are running aiir filters, that is your problem. It will get loaded up with snow dust and restrict air flow. You should try and get the stock air box and use it in place of filters. Filters are only good for for grass drags if at all.
 

·
Registered
Joined
·
2 Posts
Overall my sled runs great but for some reason when I hit the throttle wide open it boggs and restricts the rpm's at 7,000 or so...it almost sounds like there is a governor on engine.

It has smooth acceleration up to 3/4 throttle but once I hit it full it bogs and I have to back off.

If I hit it full throttle off the line it also boggs.

I have cleaned the carbs but don't know what else to do....any suggestions??
I had this issue with one of my sleds turned out it was the throttle kill switch assembly there is a safety cut out sensor inside these switches and once they were out the switch send a signal to the sensor to cut the engine that could be why when you push your throttle past half it dies out when I had the same issue after I found out about this problem I replaced my throttle kill switch assembly and the sled ran great again mybe try replacing your throttle kill switch assembly it might fix the problem
 
1 - 11 of 11 Posts
Top