Snowmobile Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 95 XCR600 and it is having a backfire problem. It was fine the first time i took it out this season then when i recently tried to start it out it backfired though the intake and a flame came out my airbox. I had it started for a minuet or two but it wouldnt build rpms and died. What is wrong, and what can i do about it?
 

·
Registered
Joined
·
77 Posts
You are forgetting that Ski-Doos are the back firing champions.Every MXZ I see backfires when shut down.
Just my $0.02
 

·
Registered
Joined
·
3,634 Posts
never heard that before. the polaris fans aren't as crazy as the cat riders... they could (not saying that they do, so someone cant tell if its a joke) have the worst sleds and still think they have the best. i know the rev is a good sled, so i support it. AC could come out with a snowmobile with no skis, so it drags the front end and cant steer it, but to them its the best! at least you recognize flaws.
 

·
Registered
Joined
·
106 Posts
Sounds like it's running to rich to me. Take it to the local shop and have them synch and set the carbs.
 

·
Registered
Joined
·
329 Posts
I agree with Jethro as well. But back fires can be caused by a lean condition as well. What condition are the plugs in? Wet and oily or dry & burnt?
Either way I suggest you pull the carbs make sure they are definately clean after the long storage. Could be as simple as a plugged jet, allowing the air to gas ratio to be to high & pre ignition, and BOOM, back fire.

Sorry but I have too....
skidoo_magoo, this is a HELP forum for Polaris. Take your opinions of what is best to the General forum. All 30 of your posts have been verbal vomit just to hear yourself talk. When your daddy stops fixing/buying your toys your gonna need help, I for one will laugh & point at you. Grow up, post something constructive or don't post at all!
skidoo_magoo congrats you just made my ignor user list!
 

·
Registered
Joined
·
3,634 Posts
i am sorry for all the comments i've made. it was a joke. that's it. friendly competition.i apologize to the people who needed help, but im sure they understand it was a joke. it's just what i do...its like ADD, i hear polaris, and i have to make a joke. sorry chase.
 

·
Registered
Joined
·
19 Posts
Grow up guys.
This happened to my sled.

You need to get the carbs cleaned and drain all the fuel out. Put in a full tank of 92 octane with seafoam. Then watch out for clogged fuel filters. "The solution to polution is dilution." It should be a miraculous recovery as mine was. Good luck!
 
1 - 8 of 8 Posts
Top