Snowmobile Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I actually have a couple of problems with my jag but most are fixed. Heres how it start found out that one of my gasket came lose and were pulling air in and it wasn't running good because of that, then i found out after that it wont start w\o starting fluid then i runs and starts fin. what could the problem be? Is there a way to adjust the carbs becuase my plugs are wet when i pull them off adn then it still wont start.
 

·
Registered
Joined
·
570 Posts
Keep using starter fluid and you won't have an engine left to worry about. Can you say bent rods and broken pistons?
 

·
I am Spartacus
Joined
·
23,863 Posts
skidoobudman8 said:
i think smallengineguy will have a solution to your problem, not just smart comments. hang in there.
The carbs need to be taken apart and cleaned, as well as the floats set. Starting fluid is bad for your engine, can burn a hole in the piston. You should get a spray bottle with mixed fuel in it to use. Make sure the choke is working correctly as well.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
carbs have been taken apart and clean so has the float but i haven't thought about the choke ill try that out.
 

·
Registered
Joined
·
329 Posts
I knew you would be able to help this guy out. I realize the starting fluid is a bad thing, but the guy needed some "real" help, not "rubbing salt into his woulds".
 

·
I am Spartacus
Joined
·
23,863 Posts
If you look at just about any of Vector's posts they are usually negative and unhelpful. You get used to it after a while......;)
 
1 - 7 of 7 Posts
Top