Snowmobile Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
2000 xc 500
the crank twisted out of phase last winter so got the crank done,rebuilt top end,cleaned carbs(more than once to be sure).my problem is it doesn't run proper.it has a large bogg that if you feather the throttle you can get through it,but if you hit it fast the engine does not speed up and it backfires.the crank is perfectly timed.we even swapped out other parts to rule everything out.the only thing i have not been able to swap is the stator.i think this is the problem.WHAT DO YOU THINK? Also if the stator is gone would this have led the the crank being twisted? Thanks
 

·
Super Moderator
Joined
·
16,797 Posts
Have you tried turning the fuel screws out? I'm not sure on the XC, but the RMK 500 engine the fuel screws should be 1/2 turn out from lightly seated. Turning the fuel screws out will give you a bit more fuel at idle.
 

·
Registered
Joined
·
615 Posts
are you sure you have the timing right did you check it with a timing light.sounds like it could be firing to early advanced to much which could cause crank to twist/backfire .could be your pulse sensor on your stator thats bad.is the tab on the fly wheel still on the flywheel that triggers the pulse sensor which tells it when to spark.im guessing you tried coil and cdi swap.do you know what caused the crank to twist originally.another though maybe you have a on/off switch going bad or your throttle is out of adjustment causing it to shut off for a second the refire causing backfire.try unplugging the black wire by the main plug in the harness near the recoil it has a white plug usually round that will bypass all your shutoffs and saftey switches.something easy to check.
 
1 - 3 of 3 Posts
Top