Snowmobile Forum banner

1 - 15 of 15 Posts

·
Bryan K
Joined
·
8 Posts
Discussion Starter #1
I have a 1972 johnson skee horse snowmobile, im new to snowmobiles and dont know much about them, i am looking for any information on this sled, oil/fuel mix ratio, i inherited the snowmobile, got it running, new fuel lines, replaced fuel lines and tank it runs ok, the pull cord doesent work but i can wrap a rope around the other side by the clutch and get it to start, it has the number 25 on the side under the seat some info on this sled would be helpful, i cant seem to find anything on it online
thanks, bryan
 

·
Registered
Joined
·
211 Posts
OMC 2 cycle opposed twin, 30hp. Download and look at the repair manual that the guy above left you a link for, it tells you just about everything you will want to know.
 

·
Bryan K
Joined
·
8 Posts
Discussion Starter #7
thanks another quick question, are these sleds rare? if i was to sell it what would i expect to get out of it? i have no idea
bryan
 

·
Registered
Joined
·
470 Posts
Taken from an ad on Craigs List in Green Bay WI.

For sale is a 1971 Johnson Skee-horse snowmobile that is in excellent condition. It has electric start and reverse. Seat and body are in great shape. Asking $400

So depending on condition, not a lot.
 

·
Bryan K
Joined
·
8 Posts
Discussion Starter #10
another question, i replaced all the fuel lines and vacuume lines, b4 i replaced them the fuel pump was pumping fine, now i cant get the thing tp pump gas, i can get it to start with spraying gas in the carb but it wont suck up the gas, is it possible that i used to large of fuel lines? any help would be great
 

·
Bryan K
Joined
·
8 Posts
Discussion Starter #12
no its not to soft, its pretty hard line, i also may have put lines on wrong, is there a diagram that i could use to fuel/vac line placement?
 

·
Bryan K
Joined
·
8 Posts
Discussion Starter #14
all the vacuume line are on correct now, its sucking the fuel but it wont stay running, like i sd b4 it was fine with the old fuel lines, maybe im using the wrong type of lines? im going to switch it out for a smaller line and see if that helps, another quick question, the slep i have has no reverse or electric start, is that normal, all the ones i have herd of have one or the other or both ? can u add electric start to it?
 

·
Registered
Joined
·
1 Posts
i know this is kinda a old post, but im gunna comment anyways. on one of your gas lines theres a one way valve. when you pull the engine over/runs, it allows fuel to flow. but when its off, or stored, the ball 'falls back' not letting the back flow of fuel. im assuming theres an absence of that valve, and it may not want to build fuel line pressure, because that valves gone. just a thought, something to try.
 
1 - 15 of 15 Posts
Top