Snowmobile Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
It is a 98 Arctic cat ZR 500 low to mid range is rich Here is what i have done. Stock e-clip in in 3rd position in have it in the 2nd which is leaner and I have the tempa flow srcew about 1/8 to 3/16th turn to the right if i put the screw at factory position the plugs are white so i keep turning the screew a little till the plugs look good in the mid to high end (Cardboard brown)

The problem is idle to 30mph like going thru town or waiting for trafic It will load up with in 30 sec at idle or 1/2-1 mile at 30mph.
 

·
Registered
Joined
·
711 Posts
My RMK did the same thing. For me it was not only the clip osition, but the jetting as well, i used different jets per temperature (outside temp). I also turned the air screw all the way in, then drive it. from a sitting position, jump on the gas, it should bog, adjust the air screw 1/4 turn out and try it again, should be about 1 to 1.5 turns total keep doing this till it gets better. when you think it is great, do one more 1/4 turn out. it shoud start to get worse. Once it gets worse, turn the screw back in 1/4 turn, this will take care of your bogging. Well it did in a polaris anyway.

just remember to do the same to both carbs at the same time so all is equal. i also installed a boost bottle to help clean things up. It was 35 bucks and it connects both carbs to equalize them more. I think SLP made mine, if you have carbs, they should make one for you as well. now my power band is from 0 to 90 instead of the 30-90 i had, i also get better fuel milage

dano
 
1 - 2 of 2 Posts
Top