Snowmobile Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
IS there a way to test my CDI box the motor seems to lose a third of its power after running for a while
 

·
Registered
Joined
·
33 Posts
The CDI can not be tested , but the stator and coils can . if they pass their tests and you still have an ignition problem , then its the CDI....but the stator is the most common problem.....Jari
 

·
Registered
Joined
·
2 Posts
I have a similar problem where my 96 ultra will run great for a few minutes until you let off the throttle and it just quits. After checks, determined that there is no spark but after a few minutes I get faint spark and an little longer and its back to normal and will start great. Any ideas????
 

·
Registered
Joined
·
711 Posts
COil or stator in that order.
What he said. Here is a video I put together showing how to check and replace a stator. Even though it is a cat, the same principles apply for both testing and replacing:

Stator testing out of a sled
YouTube - Stator Testing a 2 Stroke Stator


Stator testing in a sled:
YouTube - Stator Testing in a sled


Stator removal:
YouTube - Installing a Stator Pt.1 Removing it


Stator reinstall:
YouTube - Installing a Stator Pt.2 Putting Everything Back Together
 

·
Registered
Joined
·
2 Posts
I originally thought about the coils, however I have a hard time believing that all three of them would show the same symptoms at the same time. Agree or disagree?
 

·
Registered
Joined
·
711 Posts
I originally thought about the coils, however I have a hard time believing that all three of them would show the same symptoms at the same time. Agree or disagree?
If you have 1 bad coil and they have a jumper wire between them (like Cats do) it can effect all 3.
 
1 - 8 of 8 Posts
Top