Snowmobile Forum banner

1 - 3 of 3 Posts

·
Mopar crazy
Joined
·
277 Posts
Discussion Starter #1
I'm trying to do a little research for my buddy. He's got a 2009 Yamaha Grizzly 350, and he says its not revving up and has no acceleration. He said when he starts it and lets it idle it runs just fine, but if he tries to give it any throttle, it acts like it hits the rev limiter. He's done some research himself and found where some people had replaced the CDI box. With the research I've done, I read where possibly brake cables or shifter cables were out of adjustment. I'm going to take a look at it for him and see if I can figure something out. Obviously I'm going to look at the carburetor, plug, etc. first to make sure it's not something simple. I'm wondering if anyone else has had this problem, or possibly can point me in the direction of what could be wrong. Thanks for your input and help
 

·
Premium Member
Joined
·
5,737 Posts
Believe it or not, that can be a $5 fix with oem parts if your description is correct and my diagnosis is as well. From what I read, you should give my advice a try.

If your buddy likes to buy cheap fuel with ethanol, and the atv sits for extended periods, I may be directly responsible for saving you and your friend some serious cash. Little known to most Yamaha atv owners with carbs, and this was(is) dealer/tech info, that if you can only find from those privy to the info, that all you need is a couple of o rings replaced on the nozzle portion of that pumper carb to make it behave like new.

You wont be able to duplicate these unless you have a custom o-ring dealer at hand, but your looking for Yamaha part# 93210-10118. Dont cross check that part number for fitment as it comes up for many models over many years and none apply to the carbs. Trust that I have been in your situation and have some inside knowledge.

By the way, there is no "western", its either north or south. Where you at?
 

·
Mopar crazy
Joined
·
277 Posts
Discussion Starter #3
I know exactly what you're talking about. Actually had to replace those on my big bear a couple years ago, although my was acting differently. Mine would run alright then have a fit every now and then and run like crap for a while. I will definitely give that a try once he gets it to me. Thanks for your time and input.
Also I'm guessing you're asking northern or southern Idaho? I actually live in Council now, not sure if it'd be considered northern or southern. Kinda in the middle
 
1 - 3 of 3 Posts
Top