Snowmobile Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
i bought a 2010 polaris rmk 800 this year its the 144, and its been great except on thing, i have about 600 miles on it so far and i have an antifreeze problem. I keep gaining antifreeze, for a while it would go up and down drasticly and people kept telling me it was an air lock, so we bled it out and rode and bled it out and rode and kept doing it till i had anough and told the dealer and they told me to bring it in, so i did and they didnt find anything wrong, so i rode it and it would gain so much preasure that the antifreeze level never left the top of the cap, hot or cold engine, finaly i took it back again and they decided to change the head orings, so they did and i went and picked it up and brought it home only too see an emprety coolant bottle, so i called them and they told me to bring it back its an aitlock, so i did, and finally they got it sitting at the right level, except when it cooled down that night the antifreeze dropped about 4 inches in the reseviour, there is not antifreeze loeakign out the bottom tho, so i rode and bled it again, then let it sit and took it out today starting with the engine cold sitting over night and i put antifreeze in it up the the coldfill line, rode it for 20 miles and the hotter the engine got the higher it rose, until yet again, it hit the top of the bottle, and now sitting in the garage for 5 hours, in never went back down and thats where it sits all the time, right at the top, someone please lead me in the right direction everyone that i ask is baffled aswell as the dealer....runs strong and theres no oil in the antifreeze. i am at a loss as to whats happening
 
1 - 1 of 1 Posts
Top