Snowmobile Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
90 Exciter. low heat or no heat on the grips. I have checked all wires, grips and resistor. All seem good from the readings I have taken. My manual says tests grip warmer coil 1.6ohms. Do I unplug harness from Stator and test the Y/B and B wire to the stator for this reading?
Can this coil be replaced? or is the entire stator. Lights work but dim at times good at higher R's Any help at all would be appreciated.
 

·
Premium Member
Joined
·
5,737 Posts
the grip spec is resistance in the grip itself. the yellow/black to black should show voltage. the lighting coil should be an independant part, your right on the borderline for the upgraded ignition system.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I had both grips unhooked and read 3.3 ohms. I check y/b and black coming up to the grips with the machine running and got .5 volts. The resistance check in my manual is specific and shows the test for the "grip warmer coil" but doesn's show very well in the picture. THey show the test being done by the plug coming from the stator unhooked from the plug going to the lights and grips? They said this was 1.6 ohms. I looked all through parts and searched did not find a "grip warmer coil" that is why I wondered if it were on the stator?
 

·
Premium Member
Joined
·
5,737 Posts
i would about have to see what your reading to grasp it. whats the lit# on your manual?

usually if your testing anything per the manual you are given specific wire colors and combinations with an ohm spec at a given temp.

the coil your referring to could be part of another coil, a resistor in-line or the stator.

since your in the test mode, check all the ignition components per your manual. i will see what i can find on this end.
 
1 - 5 of 5 Posts
Top