Snowmobile Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
hello, just picked up a nice 88 el tigre 6000 and i need to clean the fuel system and carbs, can someone tell me the use of the`` switch emergency carbs`` on the side of the carburetor it must be heated carbs and could it be bypassed, any advice on pulling the carbs off there isnt much room .
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
heated carbs

on the side of the carb is a peice attached to the carb with a wiring harness it must be heated carbs...it looks like they are not working and to replace the emergency switch from BROWNS is 145.00 a side
 

·
Super Moderator
Joined
·
17,904 Posts
I took a look at the microfiche, that is a rare carb indeed! I have never seen one with electronics like that. Interesting, keep us posted on what you find.

To remove the carbs, loosen the clamps on the engine and try to push the carbs into the airbox, that should allow you to turn them enough to free them from the airbox. That is also an interesting setup. You are right, a lot of stuff in the way!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #5
I am thinking about changing out the carbs and running k n filters instead of the airbox...the sled is not running good and was wondering if these switches could be the problem
 

·
Premium Member
Joined
·
34,103 Posts
Ok, that makes it the 530cc engine then.
That is an emergency fuel shut off switch, is it is not working, you may be able to take it to an auto parts store and match up the #s and replace it for much cheaper.
Otherwise, just get the carbs from a later model 530 to throw on there.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
thanks JR.... WOULD IT BE POSSIBLE TO DISCONECT THE WIRES TO THIS SWITCH AND HAVE IT STILL RUN , IT DOES RUN BUT POORLY AND APPEARS IT WAS NOT HOOKED UP FOR SOME TIME.. NEW TOO ME SLED GLITCHES ,IM WITH YOU GET RID OF THESE CARBS ,, AND THINKING ABOUT TAKING THE AIR BOX OFF TOO JUST TO MAKE MORE ROOM FOR CHANGING JETS....THANKS AGAIN....
 

·
Registered
Joined
·
58 Posts
Discussion Starter #9
dug deeper tonight and found both saftey switches disconnected with 2 jumper wires on the main wiring harness.... i unplugged the tss and installed the jumper from the tool kit and it fired right up and ran pretty good so i am thinking theres the problem. what do i need to get the kill switch to work.....thanks for your time
 
1 - 10 of 10 Posts
Top