Snowmobile Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
I have just installed a fully charged battery in my 1985 Yamaha Phazer. When I turn the Key, I hear one click and then nothing. Then if I try it again, not even a click. I have tested the battery and know that that is not the problem. Any ideas?
 

·
Premium Member
Joined
·
5,737 Posts
check the connections as well as the condition of the relay/solenoid. also, check the contact points on the in-line fuse. i have seen both these components corrode/rust and limit connection. lastly, check the starter motor as RJ mentioned.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6
How to I test the solenoid? I managed to get the thing to make a noise like electricity was trvelling through the wires but still can't get the motor to turn.
 

·
Premium Member
Joined
·
5,737 Posts
check the starter motor first. just connect power to the starter itself at the pos terminal and put the ground from your power source to the body of the starter and see if it spins. seems like you could jump the solenoid but without one in front of me i cant tell you how. i know they can be ohm tested as well, but i dont have the procedure available at this time.
 

·
Premium Member
Joined
·
34,103 Posts
There are 3 or 4 terminals on the solenoid, to test, jumper the thick cable connections and see it the starter will try to spin.
Use the small terminals to test if it is functioning, one will be ground and the other is hot feed from the key switch.
 
1 - 8 of 8 Posts
Top