Snowmobile Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
have 85 polaris 400 l/c indy , mag side cylinder runs cool at idle, seams to have vac leak, changed mag side seal and top end gaskets , has good compression both cylinders ,checked cdi ,switched wires , carb flanges new , sprayed cleaner all over to find leak , can hold hand over right carb, no change in engine, left side kills engine, any sugg helpful, am i missing something simple
 

·
Registered
Joined
·
74 Posts
A couple questions- What do you mean cool? Is the mag-side not firing at idle but at higher rpm's is fine? From what you say, it doesn't seem like you have an air-leak. Is the plug sparking for sure? Need more info to help you.
 

·
Registered
Joined
·
44 Posts
from what i gather it is not running on that cylinder at idle. pull that carb apart and clean out your pilot jet and /circuit.if it is not getting fuel it wont make a difference when you cap the carb .if it had an air leak and you capped the carb the revs would deffinately drop imo.like sdlawndawg said we need more info:D
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
first just wanted to say thank you for the replies , problem was with carbs i set the floats to high, wasnt using correct gauge height was flooding out cylinders till it cleared, 2nly checked lower cylinder gasket and gasket holes for air flow are smaller on left side than right and intake pressure doesnt appear to be the same thats why i could hold hand over carb and seamed like vac leak, believe gasket holes are larger because right side has to run fuel pump, again thanks , because i pulled carbs to check and found problem
 
1 - 4 of 4 Posts
Top