Snowmobile Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
hello everybody need a bit of help
started the sled up for the first time this year and when i rev. it up the track wont stop spinning
i noticed the primary clutch wont disingade slides in but wont slide back out
is there something broken of just rusty and stuck from over the summer, any help would be thank full
thanks
todd
 

·
Registered
Joined
·
2,861 Posts
Pull the cover and mark it so the cover plate goes back as it was as it is a balanced clutch. Primary springs go bad all the time. It doesn't have to be broken in order to not engage properly or work as it should. They are a wear item that should be replaced every 2000-3000 miles depending on how aggressive you ride. Also I use something called Comet Clutch Lube on my primary clutches as well. Basically all it is dry graphite spray like the stuff below in the picture. Also clutches should be taken apart and cleaned every preseason including the secondary. Check the secondary buttons as well while it is apart and clean up that helix.



Tin Liquid Aluminum can Beverage can Tin can
 

·
Registered
Joined
·
2,861 Posts
Yes but mark it as it is a balanced clutch. Idk how many miles are on it but I would consider replacing the spring they are not that much and as I said just because it is broken does not mean it isn't worn and in need of replacement.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
thanks guys i will give it a try and clean every thing up, there is only 400 miles on the sled so i think the spring will be ok
i think it is just from sitting all summer.
 
1 - 6 of 6 Posts
Top