Snowmobile Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 1992 Indy RXL 650 that just started giving me clutch issues today.
You can actually watch the primary clutch engage, but immediately after it does - no matter the rpm - it starts "popping" out and immediately back in. It is literally engaging and disengaging continuously throughout the entire RPM range.

I am relatively new to snowmobiles, so I am still trying to understand just how this clutch fully works. Am I looking at a new clutch, or perhaps just a clutch spring?

Any input would be greatly appreciated!
 

·
Repair Shop Owner
Joined
·
528 Posts
Yea it is sounding like the spring is broke or has gone bad. The spring holds the sheve's open and centrifugal force make the ramps push on the rollers and the spring to close the sheves. You are going to have to take the clutch apart and find out what going on.
 

·
Registered
Joined
·
121 Posts
Could have siezed weights, bad rollers.
 

·
'93 Phazer and The Kid
Joined
·
1,145 Posts
Pull off the outer cover and see if the spring comes out in more than one piece.... Rollers and weights should move freely....
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Yea it is sounding like the spring is broke or has gone bad. The spring holds the sheve's open and centrifugal force make the ramps push on the rollers and the spring to close the sheves. You are going to have to take the clutch apart and find out what going on.

I'll do that today. Thanks!
 

·
Registered
Joined
·
608 Posts
are you sure you are experiencing a problem with the clutch? You may be having a porblem with the chain or even the track. If the track is excessively loose or the drive cogs on the driveshaft are excessively worn or damaged the track could "ratchet" when you try to accellerate. The same thing goes for the chain in the chaincase. If the sled is equipped with reverse the drive gear at the bottom may be damaged or not completely engaging which would also cause ratcheting. Generally if the drive clutch components are sticking you will have problems with it not disengaging as you return to idle. same goes for a broken clutch spring.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
are you sure you are experiencing a problem with the clutch? You may be having a porblem with the chain or even the track. If the track is excessively loose or the drive cogs on the driveshaft are excessively worn or damaged the track could "ratchet" when you try to accellerate. The same thing goes for the chain in the chaincase. If the sled is equipped with reverse the drive gear at the bottom may be damaged or not completely engaging which would also cause ratcheting. Generally if the drive clutch components are sticking you will have problems with it not disengaging as you return to idle. same goes for a broken clutch spring.

I suppose that that is entirely possible. I will take a closer look.
I am certain though that when watching the clutch first engages, that it immediately "opens" and "closes" over and over again.

Thanks for the reply!
 

·
Registered
Joined
·
608 Posts
yes well the clutch could be doing that because there would be no load each instant that whatever is wrong in the drive skips and ratchets. then when it catches there would be a load.


Watch your secondary clutch when this is happening see if it is staying stationary while this is going on. If you pull on the brake at the same time it should stop the jackshaft from moving. Try that for a sec and see if the clutch still cycles, just dont burn out your belt.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
yes well the clutch could be doing that because there would be no load each instant that whatever is wrong in the drive skips and ratchets. then when it catches there would be a load.


Watch your secondary clutch when this is happening see if it is staying stationary while this is going on. If you pull on the brake at the same time it should stop the jackshaft from moving. Try that for a sec and see if the clutch still cycles, just dont burn out your belt.


It is interesting you mention burning out my belt. Something that I didn't relay earlier on was that my wife sister-in-law was ridding the machine when she got it stuck in the snow. Apparently she throttled the machine multiple times trying to get it unstuck - even though the track was not spinning - until she eventually gave up. She and my wife managed to pull the machine out, but it was after that that this noise manifested itself. Someone told me today that she probably "glazed" the belt, and that a new belt would likely fix me up!

I still haven't had a chance to look at it, but I as before I appreciate your input. I'll take a look as you suggested.
 
1 - 9 of 9 Posts
Top