Snowmobile Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Can anyone tell me how to properly adjust the idle on a 00' 500 phazer fan cooled? I adjusted the throttle plates to match, one was open atouch further than the other was this wrong to do? Now it wont idle, so I turned the plastic headed switch on side of carb thinking it would idle up but no change. How might I reset that switch also? Any ideas would be very appreciated.
 

·
I am Spartacus
Joined
·
23,863 Posts
If you have Mikuni carbs, there should be a larger screw on the side of each carb that adjusts the idle. You should remove the airbox so you can look inside the carbs and see how the screw works.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #3 ·
They dont appear to be the typical mikuni carb, they remind me of the older setups with flat throttle plates. They also have round float bowls with the jets mounted directly into the bolt holding the bowl on if that helps the identity!?! They dont use the common idle screw. Both carbs are linked together with a common shaft that will adjust the plates in the middle of it. On the side which the cable hooks is where this sensor/switch is located that I talk about. It has a 3/4" plastic head for making a finger adjustment, this is what I took out of adjustment besides matching the plates. No other adjustments were made. Still any idea? It runs fine just wont idle now. Would it idle on just one carb?
 

·
I am Spartacus
Joined
·
23,863 Posts
It would idle on just one, but should idle on both. The large plastic screw should adjust the idle for the sled. Try to get a look at it to see exactly what the screw does. It should open the butterflies when you turn it.
 
1 - 4 of 4 Posts
Top