Snowmobile Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
ok i got the suspension out and i cut the bad track off and i got the speedomiter cable out but that trinagler shape piece that the speedo goes into with three holes for the nuts that three holed piece is like siezed on or the bearing is siezed on or something casue it wont come off the shaft how does this happen and how do i fix it thanks its a 96 formula III 600
 

·
Registered
Joined
·
711 Posts
One criticle step missed, you have to take the gears out and the drive shaft out to get that peice off and to getthe new track in. The trick is pushing the track up inside and then replacing the drive shaft. I get creative and get the track under the sled, get in the track on my back with my head forward where the rear suspension is suppose to be and wiggle and plead with it for about an hour untill it goes in. REMEMBER, the triangle peice inside the tunnel goes on the axle before you place it in the tunnle. (if i remember correctly) I think i got this right, i do it once a year but always forget a little untill i do it again


hope this helps

dano
 

·
Registered
Joined
·
275 Posts
Sometimes the bearing will seaze on. If the bearing dont move or spin then it needs to be replaced. If you are that far into it you might as well replace it. I think its a 6205 just like the idlers bearings.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
ok i got it off and now im putting it all back together and i slided the pullley back in and the seal and beraring came out now i put the seal in but the bearing wont go in all he way so does that mean the seal isnt in far anuff or what
 

·
Registered
Joined
·
275 Posts
Sorry for the delay. But either the seal is in too far or the bearing is wrong.
 
1 - 5 of 5 Posts
Top