Snowmobile Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
hey guys really need your help on this one.I have a 1977 arctic cat eltigre 5000 which has the spirit engine in it with minkuni carbs.sled would run like crazy untill it was warmed up then stall had to choke it and pull for awhile then would start back up,maybe it cooled down enough i dont know.Anyway sprayed the pto side with carb cleaner and rpms changed . took engine apart .put new seals and case ,head gaskets in put back together with proper silicone torqed everthing to spec now engine does not even have to be warmed up .runs like crap right out the gate. seems like its not getting fuel.It will idles all day when you give it to it it bogges down and stalls got to choke and starts right up.dont know if its fuel or electrical rebuilt carbs and fuelpump new coil and wires plugs the only thing left is cdi box stator assembley.
 

·
Registered
Joined
·
5 Posts
allright ,will pull them this morning and see whats going on .
It is also good to change out the gas lines and breather lines. They become very brittle and may develop cracks, cheap fix and it makes pulling the carbs out easier when the fuel lines flex.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
thanks for help.
been working on these vintage sleds for yrs,i went through this whole machine top to bottom....i thought..lol took carbs apart and cleaned again because i know you can miss alot the first time before putting back in ipulled the fuel line out of gas tank . tada...piece of old gas guage stuck in line ... important lesson learned here, dont overlook the simple things. when working on these vintage machines almost anything is possible.
 

·
Registered
Joined
·
2 Posts
Check your airbox, my friend had a 1991 yamaha phazer that sat around for about 2 years and didn't get rode much and was inside of his nice new garage. The sled would idle all day no problem but hit the throttle it would bog and pretty much quit....we cleaned the carbs and everything neccessary and everything looked clean already, didn't help investigated a little more and decided to check the air box because it seemed like it had to be an air problem and sure enough...mice had packed the entire air box full of dog food, vacuumed it all out and wah la ran like a top! If we would have checked that first we would have saved ourselves prob 3 hours of taking things apart and putting back together just to find a problem that took 3 minutes. Just a thought.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
ha ha .. ill get some pics. for ya dan . i got that 77 eltigre a 88 stratos;a81 jag and get this a 1971 moto-ski 292 god i love riding that thing..lol
 
1 - 9 of 9 Posts
Top