Snowmobile Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So today I was riding along on My 2014 summit 800 ptek with a little over three thousand miles never been rebuilt and I hit a bump really hard and my sled made a weird squeak noise and it's slowed down to an idle and then shut off. So my recoil has been messed up so I went and bought a new one there were a lot of metal shavings in that area when I took it off and I put the new one on and it starts but it idles really weird and very crappy and I replace the plugs and it has not much top end and it backfires when it's idling what could my problem be?
 

·
Super Moderator
Joined
·
16,986 Posts
That sounds expensive. That squeak noise you heard is ALWAYS expensive. A lean condition probably caused an overheating issue on the exhaust side and has melted the rings and piston. Lack of oil can do that as well, as can a problem with the coolant system. To verify, pull the exhaust and look at the exhaust side of the piston skirt. I'm betting you will see a bunch of damage. You could be lucky and all the damage could be confined to the piston, but most of the time when you squeak a piston, there is also damage on the cylinder. The cylinder can be repaired, I use Millenium Technologies, US Chrome also has a great reputation Repair will be about half the cost of a new cylinder.

You also need to figure out what caused the problem. It could be a PTO crank seal or bad carb to engine boot that is causing an air leak, or even something blocking fuel in the carb. If you don't fix the cause, you will be doing the repair again after you get the cyinder/piston back on.

Good luck, welcome to the forum!
 

·
Registered
Joined
·
3,536 Posts
I've been told that these machines have a capacitor in the Mag area that comes loose, bounces around inside the mag/flywheel and can damage the stator. symptoms are similar to what you describe.
 
1 - 11 of 11 Posts
Top