Snowmobile Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
anybody make a recomendation.
right now it has a green primary spring
a D&D helix?? in the secondary.
Im not sure what specs on the helix
 

·
Registered
Joined
·
385 Posts
I've got the same sled. I run a 57-50 helix with a yellow spring in hte secondary, black spring in the primary. 55.5 gram weights. It's a pretty good setup. Good luck. Do you have any mods to your sled?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Im not sure about the clutching other than a D&D helix 120/80 came on the sled. Therse a set of those sheilds for the secondary that smooth the sides to "decrease Drag"

Its got the flat slide and im running 300 mains

Not much else done to it.
Looking into some trail pipes and a hearthrob clutch kit. and some torque arms to keep that engine in line!!!!
 

·
Registered
Joined
·
385 Posts
JonCBrand said:
Im not sure about the clutching other than a D&D helix 120/80 came on the sled. Therse a set of those sheilds for the secondary that smooth the sides to "decrease Drag"

Its got the flat slide and im running 300 mains

Not much else done to it.
Looking into some trail pipes and a hearthrob clutch kit. and some torque arms to keep that engine in line!!!!

Have you had problems with the motor moving around? Mine keep breaking the rear motor mount. First the mount broke, so I built a reinforced one, and then the HARDEND bolt broke, and the third time it pulled the bolt right out of the aluminum so I had to drill it our and retap it to a bigger size. What's yours been doing?
 
1 - 4 of 4 Posts
Top