Snowmobile Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I know this sounds repetitive but I need some assistance.


I have a 99 skidoo that had reverse added. During my first couple rides reverse worked but on occasion it would grind, when i would put it in forward and then back into reverse it would work.

However I was riding on a snowy train here in Alaska and all of a sudden I get stuck. I switched it into reverse and griding, i did the same forward and back game with nothing, When it was in reverse I could hear the gear turning but not engaging into revese, it would grind when i gassed it but the gear noise would stop when i applied the break.

I have it at the repair shop but am wondering if anyone has had this issue and what it cost to fix it. Im hoping something quick and cheap but not sure I have enough fingers. Please help, I would like to get some rides before my upcoming deployment. Thanks!
 

·
Registered
Joined
·
315 Posts
sorry to be the bearer of bad news but griding gears is never good . and it not going to be a cheap one either , all there is a fork and gear that makes reverse happen , so i
suspect that are going to have striped gears .probably two of them , i suspect a couple of hundred bucks ? unless you (or the shop) can find some good used ones . not to hard to fix , just kind of pricey. make sure you are stopped before you engage reverse.
i hope i am wrong , for your pocketbook sake , but it sure sounds bad to me.

p.s. thank you for your service on behalf of my self and my family I WOULD LIKE TO SAY THANK YOU !!!
 

·
Registered
Joined
·
12 Posts
you didnt say if you had mechanical or electronic...99 probably is rer....if its mechanical it could very well be as simple as adjusting the linkage...which takes about 3 mins...
 
1 - 3 of 3 Posts
Top