Snowmobile Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I just bought this 99 Ski Doo Formula DLX 380 for my girlfriend and its not running right. It only has 1,200 miles and is very clean. Now im not a snow mobile guy but have raced and wrenched on dirbikes for my whole life. so i know my way around a two stroke.

So I brought it home and cleaned out the carbs right away. there was a lot of crap in there since it sat for about a year. But I got them spotless and they are good to go.

then I put new plugs, a new battery, and added about 3 gallons of fresh gas in. I didnt drain the gas in there since there wasnt much in the tank and there is a fuel filter and since it runs so good. It starts up no problem and idles really clean. Then I take it out for a about 5 min ride and its runs awsome. It pulls good and idles clean after a few hole shots. Then at about 5 min of riding it will just cut out when I come to a stop or ride at a slow speed and then wont start again for a long time.

I checked a few things thinking it must be a saftey thing for the engine. so I checked the chain case oil and it is at a good level and it looks reall fresh. I then checked the premix tank and it is a little over the min mark. I figure that this shoulf be fine and the oil light would come on before it would cut out. I also checked a green fuse that was next to the battery and by looking at it it didnt appear to be blown. Im thinking that it might have something to do with the fan not coming on. I really just dont know its hard to tell when the fan should come on and really havnt checked to see if it comes on.

Im pretty frusterated that I cant figure it out and dont want to take it somewhere since I got it for a doog price and that will go out the window after doing this. but please let me know if you have any ideas. thanks alot.
 

·
Registered
Joined
·
588 Posts
kind of sounds like the problem I'm tracking down on our Jag340. It will start to die just like yours, a quick flip of the choke brings it back for 30 seconds to a minute and then it dies again. I'm checking the carb, floats and jets again, I already replaced the fuel lines, pick up and filter last year when it was doing this, checking the pulse line, and after that maybe a new fuel pump. Mine acts like it's running out of gas every once in a while. It did the same last year and then stopped and ran fine so I thought it was just working the air out of the fuel lines after I replaced them.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thanks for the info I appreciate that. I have came to th fuel pump as well. It does the same thing your saying when I put it to half choke it will run for a about 30 seconds then die. Then looking at the gas lines on the carbs i found them to be empty. So I'm gana put a new fuel pump in it and see what happens. Seems weirs to go with this low miles but the ethanol probably wrecked it. Thanks again
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top