Snowmobile Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
:confused:Hard to start keeps quiting like someone hits the kill switch when cold! After warm up still shuts down when idling and RPM irregular. I know its electrical not fuel because it starts right back up with out using choke does anyone have knowlege on this problem? Oh Ya it has D.E.S.S
 

·
Registered
Joined
·
97 Posts
had a issue with my 01 mach... when you would try to start it the engine would want to start in reverse ( it has rer) tested the stator, everything passed within manufactures specs, threw a new stator in for the fun of it, half pull ran awesome.
 

·
Mountain Man
Joined
·
423 Posts
I'm with SEG, check under motor for rubbed bare wiring and oil, gas, water soaked CDI. The stators were also a weak point being designed for 2 coils and firing 3. If you need stator get yours rewound or get new one with heavy windings from RM Stator. I'd start with harness, check/clean/dielectric grease connections, test stator and coils. It has also been recommended to move CDI to airbox to give it a better enviroment to live in. Just my thoughts Mike
 

·
Registered
Joined
·
96 Posts
They were famous for stators going out and the wiring under the engine chafing and shorting out.
I agree, had a friend with a mod same engine that would do strange intermitent things when hot, drop cyls, slowly die down at idle then no restart till cooled down. Doo knows they had a problem, probably why stators are half the price of a twin.

Dave
 

·
Mountain Man
Joined
·
423 Posts
I just ordered a new one from RM Stators for my 98 I think it was 175.00 plus freight. I think it was 150.00 to have one rewound. They also say that putting high performance coils on them eases the burden of the stator. They use Evinrude coils and MSD wires. There is a guy, Donnie over on Dootalk that sells them ready to go. Just go to the Mach tripples forum and the thread for them is usually close to the top also there are instructions on what to use to build your own on the same forum.
Mike
 

·
Registered
Joined
·
1 Posts
hey I have a mach z 809 triple triple in a mach 1 700 chassis. im having the same trouble as you and I don't know what to do... is it the stator that's making it turn off on its own???
 
1 - 8 of 8 Posts
Top