Snowmobile Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
At mid throttle the motor wil stumble a bit. It will also sometimes do it during a hard throttle. The carbs are cleaned & synced as good as I can get. Just wondering if it could possibly be as simple as a plug going bad?
I also have something strange going on with the idle. When coming to a stop I let off the throttle & it will idle @ 3000 then eventually go down to 1500 - 2000.
I know the rubber boots from the airbox to the carbs are cracking (new ones on order) but the boots from carb to cyl. seem good. Any thoughts???
 

·
Live 2 Ride
Joined
·
1,004 Posts
could be clutching, have they been cleaned , the cracked boots can cause it to be lean and idel high,
 

·
Registered
Joined
·
318 Posts
Get new boots, new plugs and clean your clutches! What are the color of your plugs right now?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #4 ·
new boots are on their way. The plugs are a good brown color.
Guess I'll be cleaning the clutches tomorrow.
 

·
Registered
Joined
·
136 Posts
my zrt did the same thing last year..it would stumble around a lil at mid range but soon as u nail it it would be fine and fire perfect....ive also noticed it idles high for a min or two then idles down...its in the shop now to get the secondary rebuilt and the carbs cleaned....the dealer told me the carbs were pretty dirty and one of the choke plungers was completley seized up...which i think that happened during the offseason but i get it back monday and we will see what it does
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
Just got in from working on it. Cleaned the clutch. It works quite a bit smoother now.
Checked the plug gaps. They were way out! Well over the .028" that they're supposed to be at. It still has a high idle. I found that just by flipping the choke lever quick it will bring it down to 1500. Do my choke cables need adjustment?
 

·
Registered
Joined
·
136 Posts
well went to pick it up today and i guess the spring for the secondary didnt come yet so hopefully she will be ready tomorrow..il let ya no what they did to it
 

·
Registered
Joined
·
136 Posts
well got that sled back today and they cleaned carbs( they said were dirty) installed a choke plunger on the one carb and then installed new secondary spring and then a new ramp in the clutch then a set of plugs...took it for a flap in the grass just to see and ran nice and smooth...skis didnt hit the ground til i let off lol so i guess we will see when it snows but so far so good
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #13 ·
I still have a high idle issue till I toggle the choke. then it will idle down to 1500.
I've checked for air leaks... cant find any. Used half a can of brake cleaner doing so.
Inspected the choke cables & plungers
Moved the needle clips one notch down & adjusted the pilot screws.
All with no success. At this point I'm almost to the unthinkable.... Taking it to a shop:eek:

Anyone have any ideas?
 

·
Registered
Joined
·
477 Posts
I have owned several zrt's and i still have my 97. I have done extensive carb and clutch tuning and the high idle after a stop is normal. Its set that way from the factory to come up on the idle circuit real slow to prevent engine fuel load up. Triples were known for that after coming to a stop after a hard ride so that was the companys answer to that. If its taking more then a minute or two to idle down then you may have another problem. Beleive me when i tell you, its going to take you some time to get those carbs tuned just right. Those 600 triples compared to the bigger triples are VERY tricky to tune. All it takes somtimes is a worn out needle (which is hard to detect) or a wore out carb slide etc. to cause a problem. Thats how picky those zrt 6's can be. Not sure how many miles are on your sled but you may have to start replacing some internal carb parts.Try to experiment a little with the carbs.... or maybe experiment alot. Let me tell you when the carbs and clutches are tuned just right those zrt's are a force to be recond with.
 

·
Registered
Joined
·
15 Posts
might be sucking air from the base gasket. Try shooting some carb cleaner at the base gaskets right after startup.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #17 ·
No air leaks. I've sprayed a can of carb cleaner all around the cylinders. No effect.
Now that I have the jetting correctly set it does idle down to normal within seconds of letting off the throttle. Keep checking the plugs & all looks good.
I think I finally have it!
 
1 - 17 of 17 Posts
Top