Snowmobile Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
I have asked a few questions before and got it straightned out some what. I am sure my jack shaft bearing is getting bad its vibrating really hard when riding, and also i was riding for about 45 minutes or so and then it started to act funny, it would then (holding it to the wood) would rev 5000-5500 back and forth for few seconds and then die. The stator tested good and the battery is brand new. I then let it sit, fired it back up and went for anothe 45 minutes or so and then it did it again, and then repeated itself one more time. The last time i went to start it and it would start but not stay running, so i had to have it towed home. Then i unloaded it and started it back up and then barely made it back in the drive way with it poping and missing and then died again. When i turn the key on the ecu blinks once and fuel pump kicks on. Its EFI and i hate it so far lol, but i am not sure what else could be wrong. Any help is greatly apprecaited, thanks you :)
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
no i havent tested that yet, but it doesnt feel like fuel issue, i had it up to 80 in matter of seconds in a field so if the fuel pressure was bad then it wouldnt top out at all that would be my gas, i have dealt with cars and a engine is an engine in my opinion some things can be similar but i am gonna try to figure it out this weekend hopefully
 

·
Registered
Joined
·
27,165 Posts
Actually yes it would! The fuel presure regulator, as it ages, gets stiffer and adds more fuel! It will run fine on top end, but load up at lower RPM. And the little washers control the throtle safty!
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #6 ·
ok i am gonna try to by pass the TSS this weekend, and what should the fuel pressure be at ??? and if i need a new one about how much do the cost, i have a fuel pressure gauge but its on my drag car, i dont know if i can use that the check it or not ???
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #8 ·
ok cool, and the jack shaft bearing looks good i put it up on its side, is there anything else that may cause the vibration ???
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #10 ·
ok cool, and when i did the tss by pass it wouldnt rev over 4500 and it couldnt get out of its own way and ran like crap, so i put it back to the way it was and it runs fine but i havent ran it hard or for a long period of time
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top